Search

Technical requirements for iCIS v2.84 (or earlier)

This section contains the complete technical requirements for iCore Integration Suite v2.84 (or earlier versions). 

Hardware requirements

For a non time-critical iCore system (typically B2B) and supporting SQL server installed on another server:

  • Processor: minimum Intel Pentium III, 1 GHz.
  • Internal memory: minimum 1 GB.
  • Hard disk drive: minimum 30 GB.

Software requirements

iCIS v3.xx requires the following software:

  • Windows Server 2003, Windows Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2, Windows XP sp 2, Windows Vista, Windows 7, Windows 8, Windows 10 (x32 or x64 in all operatives).
    • Windows Server 2012 and Windows Server 2012 R2 require iCore v2.84 or later. 
    • If you intend to use iCore Invoke or iCore API web service with default configurations to handle external events, the Windows feature HTTP activation must be enabled (if http binding is used).
    • The name of the computer(s) which will run iCore server(s) can be no more than 15 characters in length. This limitation comes from the Windows operating system and Microsoft Message Queuing (MSMQ).
  • Internet Explorer 6.0 or later versions.
  • Microsoft Data Access Components (MDAC) 2.8 sp 2 (included in installation).
  • Microsoft XML 6.0 (included in installation).
  • Microsoft Message Queuing (MSMQ) 2.0 (part of the operating system).
  • .Net framework 4.0. Note: .Net framework requires Internet access during installation.
  • MS SQL Server 2000, 2005 sp 2 or later, 2008, 2008 R2, 2012 or 2014 (2008 R2 Express Database included in ver 2.83 --> 2005 Express Database included in earlier versions).
    • Note 1: Database server collation must be case insensitive (CI).
    • Note 2: 2008 R2 Express requires .NET 3.5.1.

Optional software

The following messaging services and drivers are examples of optional software that can be used with iCore Integration Suite. 

  • WebSphere MQ Client 5.3 + CSD11 or later versions.
  • Windows Powershell v 1.0 or later versions. If not installed, some functionality will not be accessible.
    • In Windows Server 2008 R2 and Windows 7, Powershell v 2.0 is included.
  • In other Windows versions, Windows Powershell must be installed separately.
  • iSeries Client Access ODBC driver version 5R4 or later versions.
Want to know more? Let's get in touch: